ニフクラ mobile backend information

このページではニフクラ mobile backendからのお知らせを掲載しています。

(2020/03/04 13:40 追記)


本件につきまして、本日より、テスト用ドメインの提供を行います。


項目内容
TLS1.2対応ドメインtlstest.mbaas.api.nifcloud.com
提供終了日2020年6月29日(月)
備考サービスAPI(mbaas.api.nifcloud.com)のTLS1.0/1.1が廃止されたドメインです。検証以外の用途での使用はご遠慮ください。


なお、改めて対応方法および影響等について記載いたします。


■影響について

TLS 1.2未対応の場合、mobile backendへの接続が不可となります。


■対応方法について

- SDKをご利用の場合
・ 2020/3/4 時点で、テクニカルサポート対象バージョンの以下のSDKについては、TLS1.2に対応済みです。以下のバージョンのSDKを使用している場合、追加で対応いただく内容はございません。
・ テクニカルサポート対象外バージョンのSDKをご利用の場合、アップデートをお願いいたします。


SDKバージョン
iOSv3.0.0~
Swiftv1.0.0~
Androidv3.0.0~
Unityv4.0.0~
JavaScriptv3.0.0~
Monaca push pluginv3.0.0~


・ REST APIをご利用の場合
- TLS1.2のみに対応したテストドメインを提供しておりますので、お客様にて検証・対応をお願いいたします。


■参考:TLS廃止の背景

TLS旧バージョンにはセキュリティ上の問題があり、業界全体にて廃止の動きが進んでおります。
一般的に接続不可となるOSバージョン情報等も記載がございますので、よろしければ以下ブログ記事等もご参考ください。

TLS 1.0/1.1での接続無効化に関する各社状況まとめ


---


いつもニフクラ mobile backendをご利用いただきありがとうございます。


2020年6月30日(火)に、各種ドメインの TLS 1.0/1.1 を廃止させていただきます。


■ 対象となるお客様
・ニフクラ mobile backendをご利用いただいている全てのお客様


■ 変更内容
・以下のドメインの TLS 1.0/1.1 を廃止いたします
- サービスAPI: mbaas.api.nifcloud.com
- スクリプトAPI: script.mbaas.api.nifcloud.com
- 管理画面: console.mbaas.nifcloud.com
- カスタムページ: user.mbaas.nifcloud.com


※今回の廃止対応によって、Unity 2018.1 以前のバージョンのアプリは動作しなくなる可能性がございます。
- Unity SDK はサポート対象の v4.0.0 以降のバージョンであれば、Unity 2017.x,2018.1 で動作することは確認しております。


今後も、より便利に mobile backend を利用していただくために、
鋭意改善してまいります。


引き続き、ニフクラ mobile backend をよろしくお願いいたします。

 « iOS SDK v3.0.4 アップデートについて 【改善】【障害】mobile backendパフォーマンス低下について » 

推奨画面サイズ1024×768px以上

ページの先頭へ